gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2002-000197

RedHat Linux に含まれる Libpng の progressive reader におけるバッファオーバーフローの脆弱性

5.0
2007/04/01 00:00
CVE-2002-0728

JVNDB-2002-000197

RedHat Linux に含まれる Libpng の progressive reader におけるバッファオーバーフローの脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ Red Hat Linux に同梱されている libpng は、PNG 画像形式のファイルへのアクセス及び操作を行う関数群を提供するライブラリです。この libpng において、バッファオーバーフローの問題が存在します。 libpng の progressive reader に複数のバッファオーバーフロー問題が存在します。PNG データストリームにおいて、 IHDR チャンクで示されている以上の IDAT データを含んでいる場合にバッファオーバーフローが発生する可能性があります。この問題により、リモートの攻撃者は、Mozzila などの libpng を使用するアプリケーションをサービス不能状態に陥らせることが可能です。 さらに libpng には、この問題とは異なる問題が存在します。ライブラリ関数に存在する多くのメモリリークおよびバッファオーバーフローを利用される事で、攻撃者はアプリケーションをサービス不能状態に陥らせる、もしくはアプリケーションの実行権限で任意のコマンドを実行する可能性があります。 尚、双方の問題は、次の対策で示すアップデートパッケージを適用することで解消することが出来ます。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2002-000197は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度5.0N/A
CVECVE-2002-0728
公表日2002/08/19 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。