gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2004-000178

Sun JRE の ISO2022_JP$Decoder.decodeArrayLoop() 関数におけるサービス運用妨害 (DoS) の脆弱性

5.0
2007/04/01 00:00
CVE-2004-0651

JVNDB-2004-000178

Sun JRE の ISO2022_JP$Decoder.decodeArrayLoop() 関数におけるサービス運用妨害 (DoS) の脆弱性
概要
Sun Java 2 Runtime Environment には、文字コード ISO-2022-JP をデコードする際に使用される ISO2022_JP$Decoder.decodeArrayLoop() 関数において、入力された文字列を適切に扱わないため無限ループが発生する脆弱性が存在します。
想定される影響と対策
Sun JRE が稼動している Java 仮想マシンにサービス運用妨害 (DoS) 状態となる可能性があります。
JVNDB-2004-000178は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度5.0N/A
CVECVE-2004-0651
公表日2004/05/06 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。