gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2004-000204

CVS の pserver におけるヒープオーバーフローの脆弱性

7.5
2007/04/01 00:00
CVE-2004-0396

JVNDB-2004-000204

CVS の pserver におけるヒープオーバーフローの脆弱性
概要
Concurrent Versions System (CVS) には、CVS pserver として動作させている場合において、管理ファイルが CVS クライアントにより変更されたか否かを示すフラグのためのメモリ領域を適切に確保しない不備があるため、off-by-one エラーによりヒープオーバーフローが発生する脆弱性が存在します。
想定される影響と対策
CVS サーバの実行権限で任意のコードを実行される可能性があります。
JVNDB-2004-000204は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度7.5N/A
CVECVE-2004-0396
公表日2004/05/19 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。