gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2004-000480

unarj の -x オプションにおけるディレクトリトラバーサルの脆弱性

5.0
2007/04/01 00:00
CVE-2004-1027

JVNDB-2004-000480

unarj の -x オプションにおけるディレクトリトラバーサルの脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ unarj は arj 形式の圧縮アーカイブファイルを解凍するためのプログラムです。 Unarj 2.65 以前には、以下の複数のセキュリティ上の問題が存在します。 ・arj アーカイブに含まれるファイル名の妥当性の確認に不備が存在するため、バッファオーバーフローが発生する問題 (CAN-2004-0947) ・"-x" オプション指定時に利用する、arj アーカイブに含まれるパス名の妥当性の確認に不備が存在するため、)ディレクトリトラバーサル攻撃が可能である問題 (CAN-2004-1027) これらの問題を利用するリモートの攻撃者は、意図的に作成した arj アーカイブファイルを標的ユーザに送りつけ、unarj を使用して解凍するよう誘導することにより、標的ユーザの権限で任意のコードを実行する、もしくは重要なシステムファイルを上書きできる可能性があります。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2004-000480は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度5.0N/A
CVECVE-2004-1027
公表日2004/11/10 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。