gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2004-000556

Linux Kernel の vc_resize 関数における整数オーバーフローの脆弱性

2.1
2007/04/01 00:00
CVE-2004-1333

JVNDB-2004-000556

Linux Kernel の vc_resize 関数における整数オーバーフローの脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ Linux Kernel では、VT (仮想端末) コンソールのドライバ (vt.c) において vc_resize() 関数が、TCP/IP プロトコル実装のためのオプション解析モジュール (ip_options.c) において ip_options_get() 関数がそれぞれ使用されています。 Linux Kernel 2.4.28/2.6.9 以前の vc_resize() および ip_options_get() 関数には、引数に対する妥当性の確認が適切に行われていないため、整数オーバーフローが発生する問題が存在します。(CAN-2004-1333、CAN-2004-1334) これらの問題を利用するローカルの攻撃者は、不正な値を引き渡す悪意あるプログラムを実行することにより、カーネルをクラッシュさせ、結果としてシステムをサービス不能状態に陥らせることが可能です。 尚、この vc_resize() 関数における整数オーバーフローの問題を利用するためには、攻撃者はコンソール経由で悪意あるプログラムを実行する必要があります。 Ip_options_get() 関数における整数オーバーフローの問題に関しては、Linux Kernel 2.6 のみが影響を受けます。 また、上記の問題とは別に cmsg_send により ip_options_get() 関数が繰り返し呼び出されることにより生じるメモリリークの問題 (CAN-2004-1335) が報告されています。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2004-000556は、ベンダ情報及び参考情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度2.1N/A
CVECVE-2004-1333
公表日2004/12/15 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。