gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2004-000580

Sybase Adaptive Server の xp_server におけるサービス運用妨害 (DoS) の脆弱性

5.0
2007/04/01 00:00
CVE-2005-0942

JVNDB-2004-000580

Sybase Adaptive Server の xp_server におけるサービス運用妨害 (DoS) の脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ Sybase Adaptive Server Enterprise 12.5.3 以前には、以下の複数のセキュリティ問題が存在します。 ・Transact-SQL 拡張において、データタイプの操作を行う attrib_valid ファンクションにバッファオーバーフローを生じる問題 ・SQL 拡張において、データタイプの変換を行う convert ファンクションにバッファオーバーフローを生じる問題 ・SQL 拡張において、変数タイプの定義を行う declare ステートメントにバッファオーバーフローを生じる問題 ・特定のクエリプランにおいてバッファオーバーフローを生じるため、Sybase Server の権限で任意のコードが実行可能となる問題 ・カスタム Java クラスを定義する install java ステートメントにバッファオーバーフローを生じる問題 ・拡張ストアドプロシージャを実装する xp_server が、意図的に作成されたデータを受信するとクラッシュする問題 これらの問題を利用するローカルの攻撃者は、バッファオーバーフローを発生させ Sybase Server の権限で任意のコードを実行する、あるいは xp_server をサービス不能状態に陥らせる可能性があります。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2004-000580は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度5.0N/A
CVECVE-2005-0942
公表日2004/12/22 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。