gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2005-000230

gzip の zgrep において任意のコマンドを実行される脆弱性

5.0
2007/04/01 00:00
CVE-2005-1228

JVNDB-2005-000230

gzip の zgrep において任意のコマンドを実行される脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ GNU zip (gzip) は、ファイルの圧縮・解凍を行うユーティリティであり、圧縮ファイルに対して grep を実行する zgrep や、圧縮ファイルを解凍する gunzip などの各ツールがパッケージングされています。 Gzip 1.2.4 以前には、以下の複数のセキュリティ上の問題が存在します。 1) gzip 1.2.4 以前に同梱されている zgrep は、引数に対するサニタイズ処理を適切に行わない問題が存在します。(CAN-2005-0758) 現時点では詳細は不明ですが、この問題を利用するローカルの攻撃者は、zgrep に意図的なファイル名を引き渡すことにより、任意のコマンドを実行する可能性があります。 2) gzip 1.2.4 以前には、圧縮されたファイルを解凍する際に、解凍したファイルの書き込み処理とパーミッション変更の処理の間で競合状態が発生する問題が存在します。(CAN-2005-0988) この問題を利用するローカルの攻撃者は、解凍されたファイルを、特定のタイミングで任意のファイルへのハードリンクに置き換えることにより、任意のファイルのパーミッションを不正に変更する可能性があります。 3) gzip 1.2.4 以前に同梱されている gunzip は、-N フラグを指定して圧縮ファイルを解凍する際に、ファイル名の妥当性を適切にチェックしない問題が存在します。(CAN-2005-1228) この問題を利用するリモートの攻撃者は、ファイル名に ".." という意図的な文字列を含むファイルを圧縮した圧縮ファイルを送りつけ、標的ユーザに gzip で解凍するように誘導することで、ディレクトリトラバーサル攻撃を行う可能性があります。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2005-000230は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度5.0N/A
CVECVE-2005-1228
公表日2005/04/05 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。