gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2005-000318

Gaim の URL 解析関数におけるバッファオーバーフローの脆弱性

7.5
2007/04/01 00:00
CVE-2005-1261

JVNDB-2005-000318

Gaim の URL 解析関数におけるバッファオーバーフローの脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ Gaim は、MSN などの多くのメッセンジャーと互換性を持ち、IRC クライアントとしても動作する IM (Instant Messenger) クライアントです。 Gaim 1.2.1 以前には、以下の複数のセキュリティ上の問題が存在します。 1) Jabber および SILC などの特定の IM プロトコルにおいて、メッセージに含まれる URL の長さの妥当性が適切に検証されないため、バッファオーバーフローが発生する問題が存在します。(CAN-2005-1261) この問題を利用するリモートの攻撃者は、8192 バイトを超える URL を含むメッセージを Gaim に送りつけることで、結果として Gaim を実行するユーザの権限で任意のコードを実行する可能性があります。 尚、IM プロトコルによりメッセージ長が制限されている場合があるため、特定の IM プロトコルのみが問題の影響を受けることが Gaim Project より報告されています。 2) MSN メッセージを処理する際に、NULL ポインタがデリファレンスされる問題が存在します。(CAN-2005-1262) この問題を利用するリモートの攻撃者は、意図的に作成した MSN SLP メッセージを Gaim に送りつけることで、結果として Gaim をクラッシュさせサービス不能状態に陥らせる可能性があります。 尚、Red Hat Enterprise Linux 2.1 に同梱されている Gaim が CAN-2005-1262 の問題の影響を受けるかどうかは現時点では不明です。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2005-000318は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度7.5N/A
CVECVE-2005-1261
公表日2005/05/10 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。