gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2005-000325

Mozilla Firefox の javascript 形式の URL におけるクロスサイトスクリプティングの脆弱性

7.5
2007/04/01 00:00
CVE-2005-1531

JVNDB-2005-000325

Mozilla Firefox の javascript 形式の URL におけるクロスサイトスクリプティングの脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ Mozilla 1.7.7 以前、Firefox 1.0.3 以前 には、以下の複数のセキュリティ上の問題が存在します。 ・擬似プロトコル「view-source:」および「jar:」において「javascript:」形式の URL が指定された場合に入力データの検証が不適切であるため、過去に修正された mfsa2005-37 の問題と同様の手法によりクロスサイトスクリプティング攻撃が可能となる問題 (CAN-2005-1531、mfsa2005-43) また、コードをネストさせることにより、スクリプトセキュリティマネージャによるチェックが回避され、不正にスクリプトを実行される可能性があります。 ・JavaScript の eval() 関数およびスクリプトオブジェクトの呼び出しにおいて権限の管理が不適切であるため、これらがより高い権限で実行されてしまう問題 (CAN-2005-1532、mfsa2005-44) これらの問題を利用するリモートの攻撃者は、意図的に作成した Web サイトに標的ユーザを誘導することにより、結果的に重要な情報を奪取する、あるいは任意のコードを実行する可能性があります。 尚、Thunderbird 1.0.2 以前が CAN-2005-1532 の問題の影響を受けることが Mozilla Foundation より報告されています。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2005-000325は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度7.5N/A
CVECVE-2005-1531
公表日2005/05/12 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。