gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2005-000444

KDE の Kopete Gadu-Gadu における整数オーバーフローの脆弱性

7.5
2007/04/01 00:00
CVE-2005-1852

JVNDB-2005-000444

KDE の Kopete Gadu-Gadu における整数オーバーフローの脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ KDE には、AIM、MSN、Gadu-Gadu などの各種のプロトコルに対応するインスタントメッセンジャーである Kopete が同梱されており、Gadu-Gadu プロトコルを実装したライブラリである libgadu が Kopete において利用されています。 KDE 3.2.3 - 3.4.1 に同梱されている Kopete の libgadu.c には、Gadu-Gadu メッセージを処理する際に複数の箇所で入力の妥当性が適切にチェックされないため、整数オーバーフローが発生する問題が存在します。 この問題を利用するリモートの攻撃者は、意図的に作成した Gadu-Gadu メッセージを送りつけることにより、Kopete をサービス不能状態に陥らせる、あるいは Kopete を実行するユーザの権限で任意のコードを実行する可能性があります。 尚、Gadu-Gadu サーバにユーザ登録しサインインしていない場合は、悪意ある Gadu-Gadu メッセージを受信することはありません。 また、KDE 3.2.2 以前のリリースでは、この問題の影響を受けないこと、Gadu-Gadu プロトコルをサポートしている Gaim 1.4.0 以前がこの問題の影響を受けることが報告されています。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2005-000444は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度7.5N/A
CVECVE-2005-1852
公表日2005/07/21 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。