gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2005-000523

FreeRADIUS の rlm_sqlcounter モジュールにおけるバッファオーバーフローの脆弱性

7.8
2007/04/01 00:00
CVE-2005-4746

JVNDB-2005-000523

FreeRADIUS の rlm_sqlcounter モジュールにおけるバッファオーバーフローの脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ FreeRADIUS は、RADIUS プロトコルを実装したオープンソースのインターネット認証サーバです。 FreeRADIUS 1.0.4 以前に実装されている rlm_sqlcounter モジュールには、要求の処理に不備が存在するため、SQL インジェクションが可能となる、あるいはバッファオーバーフローが発生する問題が存在します。 現時点で詳細は不明ですが、これらの問題を利用するリモートの攻撃者は、意図的に作成した要求を FreeRADIUS サーバに送りつけることにより、結果として SQL インジェクションを実行し、バックエンドデータベースのデータを追加、変更、または削除する、あるいは FreeRADIUS サーバをクラッシュさせサービス不能状態に陥らせる可能性があります。 尚、上記の問題以外にも FreeRADIUS 1.0.4 以前に関するセキュリティ問題が SUSE Linux や Red Hat Bugzilla において報告されていますが、freeradius.org の分析によると、これらは攻撃者が悪用可能なセキュリティ上の問題ではなくバグであることが報告されています。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2005-000523は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度7.8N/A
CVECVE-2005-4746
公表日2005/09/09 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。