gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2006-000497

ImageMagick の ReadSGIImage() 関数における整数オーバーフローの脆弱性

2.6
2007/04/01 00:00
CVE-2006-4144

JVNDB-2006-000497

ImageMagick の ReadSGIImage() 関数における整数オーバーフローの脆弱性
概要
ImageMagick は、X Window システム上で複数の形式に対応した画像の表示や対話的な画像操作を行なうためのパッケージです。 ImageMagick には SGI 形式の画像ファイルを処理する coders/sgi.c の ReadSGIImage() 関数において、bytes_per_pixel、columns、rows 変数の境界チェックに不備が存在するため、ヒープオーバーフローが発生する脆弱性が存在します。
想定される影響と対策
リモートの攻撃者に悪用された場合、ImageMagick の実行権限で任意のコードを実行される可能性があります。
JVNDB-2006-000497は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度2.6N/A
CVECVE-2006-4144
公表日2006/08/14 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。