gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2013-003914

strongSwan の is_asn1 関数におけるサービス運用妨害 (DoS) の脆弱性

4.3
2013/08/30 15:36
CVE-2013-5018

JVNDB-2013-003914

strongSwan の is_asn1 関数におけるサービス運用妨害 (DoS) の脆弱性
概要
strongSwan の is_asn1 関数は、asn1_length 関数の戻り値を適切に検証しないため、サービス運用妨害 (セグメンテーション違反) 状態にされる脆弱性が存在します。
想定される影響と対策
第三者により、整数オーバーフローを誘発する ASN.1 の length 値に続いて 0x04、0x30、または 0x31 の文字で始まる (1) XAuth ユーザ名、(2) EAP アイデンティティ、または (3) PEM エンコードファイルを介して、サービス運用妨害 (セグメンテーション違反) 状態にされる可能性があります。
JVNDB-2013-003914は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度4.3N/A
CVECVE-2013-5018
公表日2013/08/01 00:00
登録日2013/08/30 15:36
更新日2013/08/30 15:36
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。