vs gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2017-001913

Ruby 用 rubyzip gem の Zip::File コンポーネントにおけるディレクトリトラバーサルの脆弱性

9.8
2017/03/23 09:47
CVE-2017-5946
JVNDB-2017-001913
Ruby 用 rubyzip gem の Zip::File コンポーネントにおけるディレクトリトラバーサルの脆弱性
概要
Ruby 用 rubyzip gem の Zip::File コンポーネントには、サイトが .zip ファイルのアップロードを許可している場合、ディレクトリトラバーサルの脆弱性が存在します。
想定される影響と対策
攻撃者により、ファイルシステムに任意のファイルを書き込むために "../" (ドットドットスラッシュ) パス名部分文字列を使用する悪意のあるファイルをアップロードされる可能性があります。
ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v2の値
深刻度 9.8 7.5
CVECVE-2017-5946
公表日2017/02/08 00:00
登録日2017/03/23 09:47
更新日2017/03/23 09:47
CVSS v3情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。