gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2003-000286

OpenSSL の不正な ASN.1 タグの値における整数オーバーフローの脆弱性

5.0
2007/04/01 00:00
CVE-2003-0543

JVNDB-2003-000286

OpenSSL の不正な ASN.1 タグの値における整数オーバーフローの脆弱性
概要
OpenSSL は X.509 証明書等で ASN.1 オブジェクトを利用して認証用情報のやり取りを行っています。 OpenSSL 0.9.6j/0.9.7b 以前には ASN.1 オブジェクトのタグフィールドの値に対する十分な境界チェックが行われていないため、整数オーバーフローが発生する脆弱性が存在します。 なお、SSL/TLS プロトコルの実装する OpenSSL 以外の多くの製品にも、本脆弱性を含む ASN.1 処理に関連する脆弱性の存在が確認されています。
想定される影響と対策
第三者はが細工した ASN.1 オブジェクトを含むクライアント証明書を、SSL/TSL 等を OpenSSL を利用して実装するアプリケーションを介して引き渡すことにより、OpenSSL がサービス運用妨害 (DoS) 状態となる可能性があります。
JVNDB-2003-000286は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度5.0N/A
CVECVE-2003-0543
公表日2003/09/30 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。