gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2004-000284

PHP の strip_tags() 関数におけるクロスサイトスクリプティングの脆弱性

6.8
2007/04/01 00:00
CVE-2004-0595

JVNDB-2004-000284

PHP の strip_tags() 関数におけるクロスサイトスクリプティングの脆弱性
概要
PHP に実装されている strip_tags() 関数には、"\\0" 等の文字列が含まれているタグが適切に取り除かれない不備があり、不正なタグを含む文字列を入力することにより、 strip_tags() によるチェックを回避して script タグを挿入することにより、クロスサイトスクリプティングの脆弱性が存在します。
想定される影響と対策
ユーザのブラウザ上で任意のスクリプトを実行される可能性があります。
JVNDB-2004-000284は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度6.8N/A
CVECVE-2004-0595
公表日2004/07/14 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。