gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2005-000006

Linux Kernel の sg_scsi_ioctl() 関数における整数オーバフローの脆弱性

3.6
2007/04/01 00:00
CVE-2005-0180

JVNDB-2005-000006

Linux Kernel の sg_scsi_ioctl() 関数における整数オーバフローの脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ Linux Kernel 2.6.x には、以下の複数のセキュリティ上の問題が存在します。 ・プロセスを物理メモリにロックする mlockall() 関数に不備が存在するため、RLIM_MEMLOCK の制限を回避可能な問題 (CAN-2005-0179) (Linux Kernel 2.6.10 以前) ・sg_scsi_ioctl() 関数には、整数の正負解釈に不備が複数存在するため、負の整数を引数として処理した場合に整数オーバーフローが発生する問題 (CAN-2005-0180) (Linux Kernel 2.6.10 以前) ・AMD64 または Intel EM64T アーキテクチャ上で動作する場合に、OUTS 命令に不備が存在するため、不正に IO ポートに書き込むことが可能な問題 (CAN-2005-0204) これらの問題を利用するローカルの攻撃者は、結果としてカーネルをクラッシュさせる、あるいはカーネルメモリ内の情報を奪取できる可能性があります。 尚、CAN-2005-0179 および CAN-2005-0204 の問題に関しては、Red Hat Enterprise Linux 3、MIRACLE LINUX V3.0/V3.0 for x86-64 に同梱されている Linux Kernel (2.4.x ベース) が影響を受けることが報告されています。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2005-000006は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度3.6N/A
CVECVE-2005-0180
公表日2005/01/06 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。