gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2005-000037

SquirrelMail の webmail.php における任意の PHP コードを実行される脆弱性

7.5
2007/04/01 00:00
CVE-2005-0103

JVNDB-2005-000037

SquirrelMail の webmail.php における任意の PHP コードを実行される脆弱性
概要
------------ 本脆弱性情報は、同時期に公開された複数の脆弱性について、まとめて解説したものです。タイトル以外の他の脆弱性情報の内容が含まれていますので予めご了承ください。 ------------ SquirrelMail は、PHP 言語で開発された高機能な Web メールパッケージです。 SquirrelMail 1.4.0-1.4.3a には、以下の複数のセキュリティ上の問題が存在します。 1) prefs.php において、読み込む php ファイルを指定する変数のチェックが不適切であるため、意図的に作成された URL により標的システム上の任意の php ファイルを読み込ませることが可能な問題 (CAN-2005-0075) (1.4.3 - 1.4.3a) 2) webmail.php において、URL より指定されたフレーム変数のチェックが適切に行われないため、SquirrelMail ページのフレームに任意の Web ページを挿入することが可能な問題 (CAN-2005-0103) (1.4.0 - 1.4.3a) 3) webmail.php において変数のエスケープ処理が適切に行われていないため、意図的に作成した URL により任意の HTML もしくはスクリプトを SquirrelMail ページに挿入可能な問題 (CAN-2005-0104) (1.4.3 - 1.4.3a) これらの問題を利用するリモートの攻撃者は、意図的に作成した URL に標的ユーザをアクセスするよう誘導し、クロスサイトスクリプティング攻撃や Web サイトの偽装を行うことにより重要な情報を奪取する、あるいは標的システム上の任意の php ファイルを読み込ませることが可能です。 尚、CAN-2005-0075 および CAN-2005-0104 の問題については、PHP の設定において register_globals が on に設定されている場合にのみ影響します。
想定される影響と対策
本脆弱性に伴う影響については、「概要」をご参照ください。
JVNDB-2005-000037は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度7.5N/A
CVECVE-2005-0103
公表日2005/01/14 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。