gauge
区分
JVN番号
タイトル
JVN
深刻度
最終更新日
CVE番号
New
JVNDB-2006-000354

GnuPG の parse_user_id() 関数における整数オーバーフローの脆弱性

5.0
2007/04/01 00:00
CVE-2006-3082

JVNDB-2006-000354

GnuPG の parse_user_id() 関数における整数オーバーフローの脆弱性
概要
GnuPG の parse-packet.c に実装される parse_user_id() 関数には、パケット長に対するチェックが不適切であるため、異常に長いユーザ ID を処理した場合に整数オーバーフローが発生する脆弱性が存在します。
想定される影響と対策
GnuPG がクラッシュし、サービス運用妨害 (DoS) 状態となる、あるいは GnuPG の実行権限で任意のコードを実行される可能性があります。
JVNDB-2006-000354は、ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
JVN情報 ※( )内はCVSS v3の値
深刻度5.0N/A
CVECVE-2006-3082
公表日2006/06/20 00:00
登録日2007/04/01 00:00
更新日2007/04/01 00:00
CVSS v2情報
全ての情報を閲覧するにはユーザー登録(無料)またはログインが必要です。